Filecoin deposit and withdrawals are temporarily disabled
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Dec 03, 2024 - 23:35 EST
Investigating
All customer accounts and funds remain completely secure. Updates will be provided once they are available.
Posted Dec 02, 2024 - 12:00 EST
This incident affected: Digital Currencies (Filecoin Deposits and Withdrawals).