Service Disruption - Intermittent page load failures
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jan 31, 2024 - 05:15 EST
Investigating
Gemini has identified an incident impacting certain web pages such as Balances and sub-account switch/transfer functionality. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Jan 31, 2024 - 03:36 EST
This incident affected: Gemini ActiveTrader™ and Gemini Web UI: Uptime SLA 99.95%.