Service Disruption - FIL Deposits and Withdrawals
Incident Report for Gemini Exchange
Resolved
We have resolved this issue and FIL deposits and withdrawals are once again operating as expected.
Posted Nov 21, 2022 - 08:46 EST
Investigating
We are currently experiencing delays to FIL deposits and withdrawals. All customers’ assets remain secure. We will provide further updates as necessary.
Posted Nov 21, 2022 - 08:33 EST
This incident affected: Digital Currencies (Filecoin Deposits and Withdrawals).