Bitcoin Withdrawals Currently Delayed

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted 9 days ago. Mar 31, 2025 - 14:31 EDT

Investigating

We are currently investigating temporary delays regarding Bitcoin withdrawals. All customer accounts and funds remain secure. Further updates to follow.
Posted 15 days ago. Mar 25, 2025 - 14:23 EDT
This incident affected: Digital Currencies (Bitcoin Deposits and Withdrawals).