Degraded Performance
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 20, 2018 - 14:21 EDT
Investigating
We are currently investigating reports of degraded performance when accessing exchange.gemini.com. We will continue to provide updates as necessary.
Posted 4 months ago. Jul 20, 2018 - 10:18 EDT
This incident affected: Gemini Exchange.