ERC-20 token Deposits and Withdrawals Temporarily Unavailable
Incident Report for Gemini Exchange
Resolved
ERC-20 deposits and withdrawals are now available.
Posted Mar 27, 2020 - 15:34 EDT
Update
We are continuing to investigate this issue.
Posted Mar 27, 2020 - 10:36 EDT
Investigating
Deposits and withdrawals of ERC-20 tokens and Gemini Dollar withdrawals and redemptions are temporarily disabled. All customer funds remain safe during this time.
Posted Mar 27, 2020 - 10:27 EDT
This incident affected: Digital Currencies (Gemini Dollar Withdrawals & Redemptions).