Credit Card registration temporarily unavailable

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Jun 16, 2025 - 16:31 EDT

Investigating

Gemini credit card registration is currently experiencing degraded performance. Updates will be provided once they are available. Thank you for your patience.
Posted Jun 05, 2025 - 00:34 EDT
This incident affected: Gemini Credit Card™.