Service Disruption - Degraded Performance on Exchange
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Mar 09, 2023 - 01:35 EST
Investigating
We have noticed some degradation on the platform. We are currently investigating the issue. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Mar 08, 2023 - 23:57 EST
This incident affected: Gemini ActiveTrader™, Gemini Mobile App: Uptime SLA 99.95%, and Gemini Web UI: Uptime SLA 99.95%.