Intermittent Transaction History Data Issues

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Aug 06, 2025 - 03:21 EDT

Investigating

We are currently investigating an issue where transactions made between August 5 and August 6 (UTC) may not appear in users’ transaction history, resulting the account balances in the transaction history not accurately reflected.

All customer accounts and funds remain completely secure. Updates will be provided once they are available.
Posted Aug 05, 2025 - 22:39 EDT