Ethereum and ERC-20 withdrawals are experiencing delays
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Aug 07, 2020 - 12:06 EDT
Investigating
Ethereum network withdrawals are temporarily delayed. All customers' assets remain secure. We will provide further updates as necessary.
Posted Aug 07, 2020 - 11:18 EDT
This incident affected: Digital Currencies (Ethereum Deposits & Withdrawals, Gemini Dollar Withdrawals & Redemptions, Basic Attention Token Deposits & Withdrawals, Orchid Deposits & Withdrawals, Dai Deposits & Withdrawals, Chainlink Deposits & Withdrawals).