BTC withdrawals are temporarily unavailable
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Sep 02, 2020 - 16:21 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 02, 2020 - 14:53 EDT
Investigating
BTC withdrawals are temporarily unavailable. All customers’ assets remain secure while we perform a required update.
Posted Sep 02, 2020 - 13:45 EDT
This incident affected: Digital Currencies (Bitcoin Deposits and Withdrawals).