Sui Deposits and Withdrawals Delayed

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Jul 10, 2026 - 10:15 EDT

Investigating

Sui deposits and withdrawals are delayed. All customer accounts and funds remain completely secure.
Posted Jul 10, 2026 - 06:52 EDT