Sign-in & display issues with mobile app.
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Aug 28, 2024 - 21:40 EDT
Investigating
We are currently investigating isolated reports of login and issues displaying balances on the mobile app. All customer accounts and funds remain secure. Further updates to follow.
Posted Aug 27, 2024 - 20:33 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95%.