Crypto transfers delayed

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Mar 26, 2026 - 08:37 EDT

Investigating

Customers may experience delays with crypto deposits, withdrawals, and related account activity. All customer accounts and funds remain completely secure.
Posted Mar 23, 2026 - 10:12 EDT
This incident affected: Crypto Deposits and Withdrawals.