Portfolio Charts Temporarily Degraded

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Jun 06, 2026 - 09:36 EDT

Investigating

Some users may notice gaps in their daily portfolio chart data.  We have identified the issue and are working on correcting.  All funds remain secure
Posted Jun 05, 2026 - 18:40 EDT