Crypto Transfers and History Degraded Performance.

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Feb 19, 2025 - 21:48 EST

Investigating

We are currently investigating an issue affecting crypto transfers and transfer history. All customer accounts and funds remain secure. Further updates to follow.
Posted Feb 19, 2025 - 20:39 EST
This incident affected: Crypto Deposits and Withdrawals.