Solana and SPL token withdrawals failing

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted 15 days ago. Mar 25, 2025 - 14:53 EDT

Investigating

We are currently investigating an issue affecting Solana and SPL token withdrawals. All customer accounts and funds remain secure. Further updates to follow.
Posted 21 days ago. Mar 19, 2025 - 17:52 EDT
This incident affected: Digital Currencies (Solana Deposits and Withdrawals).