Predictions Volume Incorrect

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 20:05 EDT

Investigating

We are currently investigating an issue causing incorrect volume data to be displayed in Predictions. This impacts the accuracy of reported trading activity but does not affect underlying account balances or the ability to place trades. Our team is actively working to identify the root cause and implement a fix.
Posted Apr 07, 2026 - 19:07 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95% and Gemini.com website.