Filecoin Deposits are experiencing delays
Incident Report for Gemini Exchange
Resolved
This issue has been resolved.
Posted Aug 12, 2021 - 21:30 EDT
Identified
We are currently working to resolve an issue impacting Filecoin deposit processing times.
Posted Aug 12, 2021 - 20:36 EDT
This incident affected: Digital Currencies (Filecoin Deposits & Withdrawals).