Degraded Performance - Issues with Uploading ID Verification for Android Users in Germany

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Aug 29, 2025 - 14:53 EDT

Investigating

Gemini is investigating reports of a potential service disruption impacting Android users in Germany who may experience issues uploading their ID verification. All customer accounts and funds remain secure. Further updates will follow.
Posted Aug 28, 2025 - 08:41 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95%.