LUNA / LUNC Price Discrepancies.
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Sep 21, 2024 - 02:19 EDT
Investigating
We are aware of LUNC and LUNA price discrepancies and are working on a fix. All customer funds and assets remain secure. We will be sure to update this page as more information becomes available.
Posted Sep 20, 2024 - 20:57 EDT
This incident affected: Gemini.com website.