Credit card transactions are temporarily delayed

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 10:54 EST

Investigating

We are aware that Gemini Credit Card transactions are temporarily delayed. We are investigating the issue and working to resolve it as quickly as possible. All customer accounts and funds remain completely secure. Updates will be provided once they are available.
Posted Nov 18, 2025 - 09:19 EST
This incident affected: Gemini Credit Card™.