Litecoin Deposits and Withdrawals Temporarily Paused

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted May 27, 2025 - 18:18 EDT

Investigating

We are currently experiencing delays with processing Litecoin (LTC) deposits and withdrawals. Please note that all customer funds and accounts remain safe. We will share updates as soon as more information becomes available.
Posted May 27, 2025 - 17:26 EDT
This incident affected: Digital Currencies (Litecoin Deposits and Withdrawals).