Downloading Statements via Web is down 11/04/2024
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Nov 04, 2024 - 18:35 EST
Investigating
We are currently investigating account statements not being able to be downloaded on web. All customer accounts and funds remain secure. Further updates to follow.
Posted Nov 04, 2024 - 17:50 EST
This incident affected: Gemini.com website.