Sui Transfers Unavailable

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted May 29, 2026 - 13:52 EDT

Investigating

Customers are unable to deposit or withdraw Sui due to upstream network issue, not Gemini issue. All customer accounts and funds remain completely secure.
Posted May 29, 2026 - 10:58 EDT
This incident affected: Crypto Deposits and Withdrawals.