Crypto Withdrawals Temporarily Delayed

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 17:42 EST

Investigating

Customers may experience a temporarily delay in crypto withdrawals. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Nov 18, 2025 - 16:26 EST
This incident affected: Crypto Deposits and Withdrawals.