Crypto Deposits/Withdrawals Temporarily Disabled
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted May 08, 2024 - 10:39 EDT
Update
We are continuing to investigate this issue.
Posted May 08, 2024 - 10:39 EDT
Investigating
Crypto deposits/withdrawals are temporarily disabled while we investigate an issue. All customers assets remain secure.
Posted May 08, 2024 - 10:31 EDT
This incident affected: Crypto Deposits and Withdrawals.