Service Disruption - Web UI, Mobile trading and Stop Limit Orders
Incident Report for Gemini Exchange
Resolved
All impacted services have now been restored.
Posted Mar 27, 2020 - 21:00 EDT
Investigating
Gemini is investigating service disruptions affecting the Web UI, Mobile App, and Stop Limit Orders. Active Trader and API functionality is unaffected. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Mar 27, 2020 - 20:48 EDT
This incident affected: Gemini Web UI: Uptime SLA 99.95%.