Service Disruption - Services Currently Unavailable
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 13:56 EDT
Investigating
Gemini is investigating reports of BTC withdrawals disruptions. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Jun 21, 2022 - 13:41 EDT
This incident affected: Digital Currencies (Bitcoin Deposits & Withdrawals).