SGD currency and trading pair availability

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted 4 days ago. Mar 28, 2025 - 22:55 EDT

Investigating

We are currently investigating an issue with selecting SGD as a default currency and trading SGD pairs. All accounts and assets remain secure. We will update this page with more information once it is available.
Posted 4 days ago. Mar 28, 2025 - 21:41 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95% and Gemini Web UI: Uptime SLA 99.95%.