Investigating Mobile App Crashes Affecting Android Users on Version 25.1016.0

Incident Report for Gemini Exchange

Resolved

Please update to 25.1016.1 for latest version
Posted Oct 17, 2025 - 18:30 EDT

Investigating

We are currently investigating mobile app crashes affecting Android users on version 25.1016.0. Our team is working to publish a fix to the Google Play Store. All customer accounts and funds remain completely secure.
Posted Oct 17, 2025 - 13:30 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95%.