Gemini Credit Card Phone Support currently unavailable.

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 09:54 EST

Investigating

We are currently experiencing an issue affecting the Customer Support phone number for the Gemini Credit Card.
Our team is actively working to resolve the issue as quickly as possible. In the meantime, please submit a support request through our Help Center by opening a support ticket.
Posted Mar 03, 2026 - 09:24 EST
This incident affected: Gemini Credit Card™.