SOL Withdrawals Unavailable
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Sep 04, 2024 - 17:25 EDT
Investigating
SOL withdrawals are currently unavailable while we investigate an issue. All customer assets remain secure. We will update this page with more information as it becomes available.
Posted Sep 04, 2024 - 16:23 EDT
This incident affected: Digital Currencies (Solana Deposits and Withdrawals).