Degraded Performance - FIL Deposits and Withdrawals
Incident Report for Gemini Exchange
Resolved
The upgrade has been completed and deposits and withdrawals are fully operational.
Posted Mar 23, 2023 - 16:54 EDT
Investigating
We are working on implementing an upgrade to our Filecoin infrastructure. Users may experience delays to FIL deposits and withdrawals until this update is completed.
Posted Mar 23, 2023 - 15:26 EDT
This incident affected: Digital Currencies (Filecoin Deposits and Withdrawals).