Notional trading balance totals are incorrect
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted May 29, 2024 - 15:04 EDT
Investigating
Customers on web and mobile are seeing incorrect values displayed for their account totals. The token values are correct, and all customer accounts and funds remain secure.
Posted May 29, 2024 - 12:13 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95% and Gemini Web UI: Uptime SLA 99.95%.