XRP Deposits and Withdrawals Temporarily Delayed

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Dec 18, 2025 - 17:35 EST

Investigating

We are currently investigating temporary delays regarding XRP Deposits and Withdrawals. All customer accounts and funds remain secure. Further updates to follow.
Posted Dec 18, 2025 - 17:03 EST
This incident affected: Crypto Deposits and Withdrawals and Digital Currencies (XRP Deposits & Withdraw).