Portfolio Balance Discrepancy

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Jun 08, 2026 - 12:19 EDT

Investigating

A service disruption is affecting visibility of assets in some customers portfolios. This affects visualization only, and all funds remain safe.
Posted May 29, 2026 - 13:30 EDT
This incident affected: Crypto Deposits and Withdrawals.