SG Whitelisted Addresses Unverified

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Oct 12, 2025 - 22:05 EDT

Investigating

Singapore clients may see their verified whitelisted addresses marked as "Unverified." We are working on fixing the underlying issue. All customer assets remain secure. Further updates to follow.
Posted Oct 02, 2025 - 10:55 EDT