Investigating issue affecting GUSD and other spot crypto Pair Visibility on Derivatives Accounts

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 15:46 EDT

Update

We are continuing to investigate this issue.
Posted Apr 24, 2025 - 06:26 EDT

Update

We are continuing to investigate this issue.
Posted Apr 24, 2025 - 05:38 EDT

Investigating

We are currently investigating an issue preventing some Singapore customers from viewing and trading GUSD and other spot crypto pairs on their derivatives accounts. All customer assets and funds remain secure.We will provide updates as soon as more information becomes available.
Posted Apr 24, 2025 - 05:38 EDT
This incident affected: Gemini ActiveTrader™, Gemini Web UI: Uptime SLA 99.95%, and REST API.