Ethereum and ERC-20 Deposits Are Delayed
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted May 30, 2024 - 23:53 EDT
Investigating
ETH and ERC-20 deposits are currently delayed. All customer accounts and funds remain secure. Further updates to follow.
Posted May 30, 2024 - 11:36 EDT
This incident affected: Digital Currencies (Ethereum Deposits and Withdrawals) and Crypto Deposits and Withdrawals.