Credit Card applications are temporarily suspended

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted 1 month ago. Jan 28, 2025 - 10:51 EST

Investigating

Customers temporarily cannot start or continue their Gemini Credit Card applications while we investigate an issue. All funds remain secure. Thank you for your support!
Posted 1 month ago. Jan 28, 2025 - 08:18 EST
This incident affected: Gemini Credit Card™.