Service Disruption - Staking on Android Mobile
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Nov 20, 2022 - 14:00 EST
Investigating
We are investigating reports that users on the Android mobile app may be unable to use staking. These customers should use the web interface instead while we work to identify and mitigate the issue.
Posted Nov 20, 2022 - 13:38 EST
This incident affected: Gemini Mobile App: Uptime SLA 99.95%.