Service Disruption - Crypto Withdrawals
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jul 08, 2024 - 11:19 EDT
Investigating
We are aware that some customers are unable to withdraw cryptocurrency on the web interface. All customer accounts and funds remain secure. Further updates to follow.
Posted Jul 03, 2024 - 12:08 EDT
This incident affected: Gemini Web UI: Uptime SLA 99.95%.