Delays in processing USD Wire Transfers
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Nov 09, 2021 - 19:01 EST
Identified
Some wire deposits may continue to experience processing delays. The issue has been identified and our team are working to improve the processing speed of inbound wires.
Posted Nov 08, 2021 - 09:50 EST
Investigating
We are currently investigating processing delays on a subset of inbound USD wire deposits. Wire withdrawals are unaffected.
Posted Nov 05, 2021 - 16:55 EDT
This incident affected: Wire Transfer Deposit and Withdrawals.