ETH and ERC-20 Deposits and Withdrawals Experiencing Delays

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Feb 11, 2025 - 20:45 EST

Investigating

We are currently investigating an issue causing ETH/ERC20 Deposit and Withdrawal delays. All customer assets and funds remain secure. We will update this page as more information becomes available.
Posted Feb 11, 2025 - 20:23 EST
This incident affected: Digital Currencies (Ethereum Deposits and Withdrawals).