Credit Card Phone Support Currently Unavailable

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Sep 30, 2025 - 12:08 EDT

Investigating

Gemini Credit Card phone support is currently unavailable. Please contact support@gemini.com for support inquiries.
Posted Sep 30, 2025 - 10:45 EDT