Temporary Pause on Cubix Deposits

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Jul 16, 2025 - 16:16 EDT

Investigating

Please refrain from submitting any new Cubix deposits at this time. Withdrawals remain unaffected and are being processed as usual.

This temporary measure is due to an issue we are currently addressing. We’ll notify you as soon as it’s safe to resume deposits. All your funds remain secure as always.

Thank you for your understanding and cooperation.
Posted Jul 16, 2025 - 10:09 EDT
This incident affected: Wire Transfer Deposit and Withdrawals.