Gemini Credit Card Support - Temporarily Unavailable

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted May 28, 2025 - 12:02 EDT

Investigating

The Gemini Credit Card support hotline is currently temporarily unavailable due to a system update. We are actively working to restore this service as soon as possible.

In the meantime, for any credit card-related inquiries, please submit a request through our support request form through the link here:
https://support.gemini.com/hc/en-us/requests

We appreciate your patience and understanding.
Posted May 16, 2025 - 00:31 EDT
This incident affected: Gemini Credit Card™.