ETH and GUSD deposits and withdrawals are temporarily unavailable
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 17, 2019 - 17:07 EDT
Monitoring
ETH and GUSD deposits and withdrawals are temporarily unavailable. All customers’ assets remain secure. We will provide further updates as necessary.
Posted 4 months ago. Mar 17, 2019 - 17:04 EDT
This incident affected: Ethereum Deposits & Withdrawals and Gemini Dollar Withdrawals & Redemptions.