Service Disruption - Bitcoin processing delays
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Nov 28, 2022 - 18:15 EST
Investigating
We are currently experiencing delays with Bitcoin withdrawals due to network conditions. All customers’ assets remain secure. We will provide further updates as necessary.
Posted Nov 28, 2022 - 16:04 EST
This incident affected: Digital Currencies (Bitcoin Deposits and Withdrawals).